مصادقة SMTP و SPF, DKIM و DMARC ليست طرقًا قابلة للتبديل لتسجيل الدخول. يقوم SMTP AUTH بمصادقة العميل على خادم SMTP . يقوم نظام التعرف على هوية المرسل SPF بتقييم مضيف الإرسال وفقًا لسياسة المغلف الخاصة بالنطاق، ويتحقق DKIM من توقيع الرسالة، ويقيم DMARC مصادقة النطاق المحاذي بالنسبة إلى "من" المرئي. يمكن أن يتواجد تسجيل الدخول الناجح للحساب مع فشل DMARC ، ولا يحتاج بريد الإنترنت الوارد إلى المصادقة على حساب الإرسال الخاص بك.
تحديد موقع العلاقة بين العميل والخادم
RFC 4954 يحدد امتداد AUTH واستخدامه لآليات SASL. تحدد سياسة ترخيص الخادم ما قد يفعله العميل الذي تمت مصادقته. إن معرفة اسم الحساب المعتمد لا يؤدي تلقائيًا إلى ترخيص كل مظروف محتمل أو عنوان "من" مرئي. عادةً ما تطبق خدمات الإرسال قيودًا تنظيمية ومرسلة إضافية.
RFC 6409 يميز تقديم الرسالة عن الترحيل. حدد الخدمة التي يستخدمها التطبيق قبل تغيير بيانات الاعتماد أو DNS . يتمتع الجهاز المتصل بخدمة الإرسال الموثقة الخاصة بالموفر بعلاقة مختلفة عن خادم البريد البعيد الذي يقوم بتسليم بريد الإنترنت إلى MX الخاص بالمجال الخاص بك. لا تحاول إصلاح حالات فشل المصادقة الواردة العادية عن طريق منح المرسلين الخارجيين كلمة مرور لصندوق البريد.
اتبع أدلة المجال المصب
يتحقق نظام التعرف على هوية المرسل SPF من المضيف المتصل وهوية المغلف ذات الصلة بموجب RFC 7208 . يستخدم التحقق DKIM محدد وتوقيع المجال في التوقيع للعثور على مواد المفتاح العام والتحقق من المحتوى المغطى بموجب RFC 6376 . يتطلب DMARC العلاقة المناسبة بين المجال العابر والمجال المرئي الموجود ضمنه RFC 9989.
يمكن لتطبيق ما المصادقة بنجاح على حساب المورد، ثم إرساله باستخدام مجال ارتداد غير محاذ ومجال توقيع DKIM غير محاذي. قد يمر كل من نظام التعرف على هوية المرسل SPF و DKIM معاً أثناء فشل DMARC . وعلى العكس من ذلك، يمكن للمجال الذي تم تكوينه بشكل صحيح تمرير DMARC على البريد الذي يتم تسليمه بين الخوادم بدون SMTP AUTH على تلك القفزة التي تواجه جهاز الاستقبال. يجب التحقق من بيانات اعتماد الحساب وترخيص المجال على حدود كل منهما.
استخدم الأدلة دون كشف الأسرار
في حالة فشل تسجيل الدخول، قم بتسجيل نقطة نهاية الخدمة وحالة النقل الآمنة والطرق المعلن عنها والخطأ الكامل، باستثناء بيانات الاعتماد والرموز المميزة. بالنسبة لرفض المرسل بعد تسجيل الدخول، قم بالتقاط سياسة المرسل المسموح به والأمر المرفوض. بالنسبة للفشل في المراحل النهائية، احصل على نتائج جهاز الاستقبال الموثوق به ومعلومات المغلف وقيم DKIM d وs والمجال المرئي من. تجنب نسخ حمولات المصادقة في التذاكر أو أمثلة المقالات.
قارن بين نتيجتين افتراضيتين
الحالة أ: يقوم العميل بالمصادقة على خدمة الإرسال ويُسمح له بالإرسال، لكن يُبلغ المتلقي النهائي عن تمرير SPF vendor.example example وتمرير DKIM بـ d=vendor.example بينما يستخدم From brand.example . بافتراض وجود سياسة DMARC سارية وعدم وجود خطأ في التقييم لم يتم حله، لن تتم محاذاة أي من النطاقين وتفشل الرسالة DMARC . لا يمكن لكلمة مرور أخرى تغيير علاقات المجال تلك.
الحالة ب: يقوم الخادم بتسليم البريد الوارد العادي إلى MX للمستلم بدون مصادقة SMTP في تلك الخطوة. يُبلغ المتلقي الموثوق به عن صحة توقيع DKIM مع مطابقة d=brand.example من= brand.example . مع وجود سياسة قابلة للتطبيق وعدم وجود خطأ في التقييم لم يتم حله، يمكن أن يوفر هذا التوقيع المحاذي تصريح DMARC . لا يؤدي هذا إلى إنشاء محتوى آمن أو وضع للبريد الوارد أو إذن لتنفيذ إجراء تجاري مطلوب. كلتا الحالتين مقارنات مخترعة؛ لم يتم استخدام أي بيانات اعتماد أو تسجيل دخول الموفر أو اختبار التشفير.
إصلاح التكوين المسؤول
إذا فشل AUTH، فاتبع طريقة المصادقة المدعومة الحالية للموفر ومتطلبات النقل. لا تقم بتفعيل آلية قديمة لمجرد أن هناك مقالة قديمة تشير إليها. إذا كان الحساب المصادق عليه يفتقر إلى إذن لاستخدام عنوان، فقم بإصلاح تكوين المرسل المعتمد من خلال العملية الإدارية العادية. إذا المصب تنسيق إذا فشل الأمر، قم بتكوين المغلف المدعوم للمرسل الشرعي أو مجال DKIM بدلاً من افتراض أن كلمة مرور أخرى ستساعد.
بعد الإصلاح، قم باختبار الإرسال والتقييم النهائي للمستلم باستخدام رسائل غير ضارة. الاحتفاظ بالنتائج المميزة: مصادقة العميل، والسماح للمرسل، وقبول الرسالة، وتقييم آليات المجال، ومراقبة التصرف النهائي. علامة نجاح واحدة تخفي الكثير. يعلمنا الدليل التفصيلي كيفية فصل هذه النتائج؛ ولا تطالب بمعالجة البروتوكول المنفذ أو التحقق من DKIM أو تكوين المستأجر.
احتفظ بنتائج قبول منفصلة
- مصادقة العميل: قم بتسجيل نقطة النهاية والآلية المدعومة والنتيجة، وليس السر أبدًا.
- المرسل مسموح به: تحقق من أن الحساب مخول لهذا المغلف والمرسل المرئي.
- تم قبول الرسالة: احتفظ بالرد بعد نقل المحتوى وخادم الاستقبال.
- تم التحقق من صحة النطاق: سجل نتائج SPF / DKIM الموثوقة ومحاذاة DMARC بشكل مستقل.
- ملاحظة التسليم: الاحتفاظ بالنتائج من جانب المستلم دون تحويل قبول النقل إلى ضمان للبريد الوارد.