[ DNSとドメイン ]

認証ルックアップにおけるDNS応答の切り捨てと TCP フォールバック

トランスポート障害と認証ポリシーの不在を混同することなく、切り捨てられたDNS応答とブロックされた TCP を診断します。

EmailAuth研究チームによる

【ポイント】

  • 切り詰められた応答は、完全な認証ポリシーの応答ではありません。
  • スタブからリゾルバへのパスとリゾルバから権限へのパスを個別にテストします。
  • 複数のSPFポリシーを作成せずにトランスポート障害を修復します。
このページでは

応答が使用可能な UDP 交換に適合せず、フォールバック パスが完了できないため、 DNSルックアップが失敗する可能性があります。大きい TXTレコード, DNSSEC マテリアルと応答の構成によって、この問題が明らかになる可能性があります。チェッカーがレコードを報告しないからといって、キーを削除したり、ポリシーを短縮したりしないでください。まず、リゾルバが完全な応答を取得したかどうかを判断します。

トランケーション信号を読み取る

参考文献: RFC 1035 §4.1.1, RFC 7766 §5, RFC 6891 §6.2.3.

DNSヘッダーの TC ビットは切り捨てを示します。欠落データを必要とするクライアントは通常、TCP を使用して再試行します。最新のDNS実装は、 RFC 7766に基づいて TCP をサポートする必要があります。 DNSは UDP 専用のサービスではありません。 EDNS を使用すると、リクエスタはより大きな UDP ペイロード サイズをアドバタイズできますが、そのアドバタイズは、パス上のすべてのネットワークがパケットを伝送することを保証するものではありません。

IP の断片化、ファイアウォール、壊れたミドルボックスは、大規模な UDP 応答に干渉する可能性があります。 TCP は、Web パネルで特定のTXT値が小さく表示されるかどうかとは無関係に必要になる場合があります。貼り付けた文字数だけでなく、応答とパスも測定します。

2つのレゾルバレッグを分離します

参考文献: RFC 7766 §5, RFC 7208 §4.4.

スタブから再帰と再帰から権威への交換は異なります。ラップトップからパブリック リゾルバーへの TCP が成功しても、メール受信者のリゾルバーが TCP 経由でユーザーの権限に到達できることは証明されません。同様に、直接権限テストでは、受信者が使用するすべての転送リゾルバーが再現されるわけではありません。

クエリの所有者、タイプ、サーバー、トランスポート、EDNS オプション、応答サイズ、フラグ、タイミングを記録します。切り捨てられた部分応答を、選択された応答の完全なセットとして解釈してはなりません。 SPF 政策。 SERVFAILとタイムアウトは、名前が存在しないという証拠にはなりません。アプリケーション レコードを変更する前に、正確なエラーを保存してください。

制御されたフォールバック障害を再現する

使い捨てDNSラボでは、意図的に小さく受け入れられた UDP 応答サイズを超えるのに十分な大きさの応答を構成します。まず、UDP と TCP の両方を許可します。同じ所有者とタイプを要求し、パケットまたはリゾルバー トレースをキャプチャします。予期される証拠には、クライアントがフォールバックを実行するときに、切り詰められた UDP 応答とその後に続く成功した TCP 応答が含まれます。

次に、選択した境界でラボの TCP パスのみをブロックします。同じ入力とキャッシュ状態を制御してクエリを繰り返します。予期される結果は、UDP 交換が機能しているにもかかわらず、その境界での完全なルックアップが失敗することです。テスト直後にルールを復元します。これはラボの仕様であり、運用ネットワークのセキュリティを変更する許可ではありません。この記事では、ファイアウォールベースの手順は実行されていません。以下の歴史的なサービスクローズ実験は、別のより限定的なテストです。

これらのオプションをサポートする BIND dig バージョンがインストールされている場合、 dig @AUTH OWNER TXT +bufsize=512 +ignore 自動 TCP 再試行なしで UDP 応答を公開できますが、 dig @AUTH OWNER TXT +tcp 明示的に TCP を要求します。ラボの値を置き換え、バージョンのヘルプを調べ、完全な出力を保持します。このレビューではコマンドは実行されていません。保持されたカスタム クライアント キャプチャでは、Dig 動作は検証されません。

ポリシーを再設計する前にトランスポートを修復する

参考文献: RFC 7766 §5, RFC 7208 §3.2, RFC 7208 §3.3.

サービスが両方のトランスポートをリッスンしていること、および承認されたネットワーク パスが必要なトラフィックを許可していることを確認します。担当オペレーターにファイアウォールまたはロードバランサーの変更を確認してもらいます。同じ回答を再テストし、意図したパスで完了をキャプチャします。

応答を運用上管理可能な状態に保つことは便利ですが、 TXT値を 1 つのレコード内の文字列に分割しても、本質的に、トランスポート障害を解決できるほどDNS応答の合計が十分に削減されるわけではありません。 1 つのSPFポリシーを複数のポリシー レコードに分割すると、個別の標準違反が作成されます。短く見えるダッシュボードの値ではなく、トランスポートの証拠と、その後の代表的な認証結果によって問題を解決します。

保存されている過去の研究室の証拠

保持されているキャプチャの日付は 2026 年 11 月 7 日です。以下では、 EmailAuth.aiの新しい実行やテストではなく、その限定された履歴観察について説明します。

分離されたDNSサービスは、大規模なTXT応答に対して空の UDP 応答を含む TC を意図的に送信しました。 TCP を介した同じ質問では、TC クリアと 512 バイトを超えるワイヤ長を含む完全な回答が返されました。テスト サービスで受け入れられた TCP 接続を閉じると、クライアントが失敗しました。ファイアウォールや運用ネットワークの設定は変更されていません。これは、強制的な切り捨ての下で実際の UDP および TCP 交換をテストします。 DNSサーバーの自動サイズしきい値や dig 独自のフォールバック実装をテストするとは主張していません。キャプチャ ラベルはlarge_udp_truncatedです。ラージ_tcp_complete; tcp_failure.json。保持されたランナーと生のキャプチャは、歴史的証拠としてこのレビュー パッケージに含まれています。それらは検査されたものであり、このレビューのために再実行されたものではありません。本番環境のDNS 、 DNSSEC 、およびSMTP結果はテストされていません。

[ 取り除く ]

複数のSPFポリシーを作成せずにトランスポート障害を修復します。

【役割別】

これがあなたにとって何を意味するか

実際の次のステップに向けて、自分の役割を選択してください。

IT / メール管理者

失敗したトランスポートレッグをトレースする

スタブ、再帰、権限パスは個別に観察する必要があります。

次のステップ

  1. TC と応答サイズをキャプチャします。
  2. UDP と TCP を比較します。
  3. リゾルバーエラーの詳細を保持します。

CISO / SecOps

制御フォールト挿入

ネットワーク ルールを変更すると、テスト クエリ以外にも影響が及ぶ可能性があります。

次のステップ

  1. 隔離されたラボを使用してください。
  2. ネットワークの変更を正確に承認します。
  3. ベースラインを復元して確認します。

創業者 / 非技術系

断続的な検索を可用性障害として扱う

受信者がレコードを取得できない間も、レコードは存在する可能性があります。

次のステップ

  1. ネットワーク所有者を割り当てます。
  2. 緊急政策の弱体化を回避する。
  3. 再現された回復証拠が必要です。

[ よくある質問 ]

よくある質問

TCとはどういう意味ですか?

DNS応答は切り詰められます。完全な答えとして扱わないでください。

RFC 1035 §4.1.1

DNS TCP は最新の実装ではオプションですか?

RFC 7766では、一般的なDNS実装に対して TCP サポートが必要です。

RFC 7766 §5

EDNS は大規模な UDP 配信を保証しますか?

いいえ。公表されているペイロード容量はパスの動作を保証するものではありません。

RFC 6891 §6.2.3

タイムアウトはSPFレコードが存在しないことを意味しますか?

いいえ。転送または解決の失敗は、認証された不在または通常の不在とは異なります。

RFC 7208 §4.4

2 つのSPFレコードでこれを修正できますか?

いいえ。複数のSPFポリシーを選択すると、永続的なエラーが発生します。

RFC 7208 §4.5

ローカル TCP の成功は、受信側 TCP が機能することを証明しますか?

いいえ、受信者は別のリゾルバーとネットワーク パスを使用する可能性があります。

TXT文字列を分割するとメッセージ全体が削減されますか?

これはレコード内の表現を保持しますが、一般的な応答サイズの修復ではありません。

RFC 7208 §3.3

この記事のためにファイアウォールが変更されましたか?

保持された履歴テストではファイアウォールは変更されませんでした。ループバック テスト サービスが受け入れられた TCP 接続を閉じました。本番環境のトランスポートとファイアウォールの動作はテストされていません。

[ 情報源 ]

情報源

  1. RFC 1035

    セクション §4.1.1

  2. RFC 6891

    セクション §6 · §6.2.3

  3. RFC 7208

    セクション §3.2 · §3.3 · §4.4 · §4.5

  4. RFC 7766

    セクション §5

  5. BIND 9 ディグマニュアル

    セクション クエリオプション

[ 用語集 ]

用語集

TCビット
切り捨てられた応答を示すDNSヘッダー フラグ。

RFC 1035 §4.1.1

EDNS
UDP ペイロード容量をアドバタイズできるDNS拡張メカニズム。

RFC 6891 §6

後退する
試行が不完全または失敗した後の、別のトランスポートを介した後続の交換。

RFC 7766 §5

企業の来歴

一流の金融機関と政府が選ばれる理由 電子メール セキュリティ ダッシュボードを廃止しました。

従来の電子メール認証プラットフォームはダッシュボードを販売し、エンジニアに作業を依頼します。一か八かの環境では、手動による監視は適用の遅れ、構成のドリフト、および監視されていないシャドウ ドメインを意味します。

EmailAuthは、エージェントの電子メール来歴プラットフォームです。 当社のエージェントが執行します p=reject、サードパーティの送信者を調整し、ドメインを完全に移動します。 RFC 9989 新しいDMARC標準に準拠し、人間による監査機能を備えています。

政府 大企業 ティア1金融機関

SaaS · 専用テナント · エアギャップオンプレミス · BYOK 暗号化

ナレッジベース