[ 地域の要件 ]

再現可能なDMARC導入調査を設計する

クエリを実行する前に母集団と分類ルールを凍結し、成功した回答とともにエラーを保存します。

EmailAuth研究チームによる · 2 分で読めます

【ポイント】

  • クエリを実行する前に母集団と分類ルールを凍結し、成功した回答とともにエラーを保存します。
  • 結果を計算する前にスコープを固定し、生の観測を保持します。新しいクエリでは過去のDNS応答を再生できません。
このページでは

A reproducible DMARC 養子縁組の研究は、その観察結果から答えられる疑問から始まります。ポリシー レコードのクエリにより、収集ウィンドウ中にリゾルバーがその名前に対して何を返したかを確立できます。組織が送信するすべてのメッセージが認証に合格するかどうか、受信者がそれらのメッセージを受け入れたかどうか、または組織が詐欺を経験したかどうかを確認することはできません。

結果を見る前にプロトコルを作成する

対象集団、サンプリング枠、観測単位を分けて記載します。ターゲットは、管轄区域内の登録機関である可能性があります。フレームは Web サイトのドメインの公式リストである可能性があります。実際にクエリされるユニットは、1 つのDNS所有者名である可能性があります。これらは異なるオブジェクトです。エンティティとドメインのマッピングをバージョン化し、ドメインが含まれる理由を説明します。収集前に除外、再試行制限、リゾルバの選択、および分類ルールを凍結して、後で不都合なタイムアウトが分母から消えないようにする。

観察結果を解釈する前に保存する

生の応答、HTTP ステータス、 DNS応答コード、所有者名、レコード タイプ、返された TTL およびクライアント タイムスタンプを保持します。スクリプトのリビジョンと、保持されているすべてのファイルのハッシュを保存します。要求された応答がない成功したDNS応答からトランスポート エラーを分離します。 DNS名エラー、空の応答、およびタイムアウトは、交換可能な検出結果ではありません。分類子がどのステータスを認識でき、どのステータスを手動で確認する必要があるかを説明します。

出版物を監査可能にする

分母とその横に未解決の観測値を付けてカウントを公開します。クエリされた人口、収集日、および分類バージョンのないグラフは、独立して解釈できません。 2 人目のアナリストに、新しいネットワーク クエリの実行を依頼する前に、凍結された応答からオフライン サマリーを再現するよう依頼します。新しいクエリは過去ではなく現在をテストします。古いデータを上書きするのではなく、両方の実行を保存して違いを説明します。

透明性のある仮説上の決定を適用する

10 個の宣言されたドメインが 6 つの候補ポリシー文字列、要求されたデータを含まない 2 つの成功応答と 2 つのタイムアウトを生成すると仮定します。試行された 10 回の観察をすべて保存します。試行された 10 個のドメインのうち 6 個の候補文字列を、2 つの空の応答と 2 つの未解決のタイムアウトとともに個別に報告します。これを 6 つの有効な展開とは呼ばないでください。構文、ポリシー検出、および送信者ドメインのカバレッジには、依然として規定されたチェックが必要です。完全な場合の計算では、異なる分母を特定する必要があります。これらの発明されたカウントは分類を説明するだけです。収集は実行されませんでした。

技術的な境界と出版の決定

RFC 9989セクション 4.7、4.10.1、および 5.3 レコード構文、ポリシー検出、メッセージ評価を区別します。正確な所有者のTXT観察は、完全なポリシー検出ではありません。 RFC 9990セクション 3.1 ドメイン クロールとは別の、集約されたメッセージ証拠について説明します。 RFC 2308セクション 2 否定的なDNS応答を区別します。クライアントのタイムアウトは不在の証明にはなりません。ここでの研究設計の選択は編集方法論であり、RFC で規定されている統計要件ではありません。この教育改訂では、歴史的なパイロットや全国的な導入の結果は示されていません。その後の実験結果には、独自のアクセス可能なハッシュ バインド データと独立したメソッド レビューが必要です。

[ 取り除く ]

結果を計算する前にスコープを固定し、生の観測を保持します。新しいクエリでは過去のDNS応答を再生できません。

【役割別】

これがあなたにとって何を意味するか

実際の次のステップに向けて、自分の役割を選択してください。

IT / メール管理者

各結果を追跡可能にする

別のアナリストがすべての数値の背後にある正確な答えを見つけ出す必要があります。

次のステップ

  1. 生の応答とハッシュを保持します。
  2. 別のスナップショットを収集する前に、オフラインで再生します。
  3. コレクターのリビジョンとタイムアウト設定を記録します。

CISO / SecOps

証拠と保証を分離する

DNS公開は、限定されたセキュリティ監視の 1 つです。

次のステップ

  1. 詐欺やメッセージのコンプライアンスに関する申し立てを拒否します。
  2. 独立した範囲レビューが必要です。
  3. 結果として生じる主張には追跡可能な情報源が必要です。

創業者 / 非技術系

リサーチクエスチョンを凍結する

市場ヘッドラインは実際の観測単位と一致する必要があります。

次のステップ

  1. 収集前に人口ステートメントを承認します。
  2. 実現可能性調査とその後の修正を個別に開示します。
  3. 公表された結果とともに研究計画書を保管してください。

[ よくある質問 ]

よくある質問

クエリを実行する前にサンプルを定義する必要がありますか?

はい。最初に選択ルールと除外ルールを記録します。実現可能性調査またはその後の修正を個別に開示すること。

公開 Web サイトのドメインは検証済みの送信ドメインですか?

いいえ。送信者と国家の別個の証拠がさらに確立されるまで、これは選択された観察単位です。

データセットにエラーが残るべきでしょうか?

はい。試行されたすべての観察を記録し、未解決の結果と否定的なDNS応答を区別します。

別のアナリストが昨日のDNSを再現できるでしょうか?

保存された回答を再生できます。 DNSとキャッシュが変更されるため、新しいクエリは異なる場合があります。

この仮説の例は全国的な導入を推定していますか?

いいえ、発明されたカウントは分母と分類の決定を説明します。それらは観察ではありません。

なぜ生のTXT応答を保持するのでしょうか?

要約には、レビュー担当者が検査する必要がある複数のレコード、異常な書式設定、または分類エラーが隠蔽される場合があります。

p=rejectメールが拒否されたことを証明しますか?

いいえ、これは要求されたポリシーです。受信者の決定とメッセージの証拠は別のものです。

公開前に何を確認する必要がありますか?

母集団の来歴、タイムスタンプ、エラー処理、分類ロジック、および主張されたすべての結果の正確な範囲。

[ 情報源 ]

情報源

  1. RFC 9989

    セクション §4.4 · §4.7 · §4.10.1 · §5.3.5 · §5.4

  2. RFC 9990

    セクション §3.1 · §7

  3. RFC 2308

    セクション §2 否定応答 · §5 否定応答のキャッシュ

[ 用語集 ]

用語集

サンプリングフレーム
観測値が選択される宣言されたリスト。必ずしも対象集団ではありません。
正確な所有者の観察
より広範な送信者資産を推測せずに、指定されたDNS名とタイプに対する応答。
未知の観測
測定を試みましたが、解釈可能な十分な証拠が得られませんでした。
観察窓
記録された収集操作の UTC 開始と終了。

企業の来歴

一流の金融機関と政府が選ばれる理由 電子メール セキュリティ ダッシュボードを廃止しました。

従来の電子メール認証プラットフォームはダッシュボードを販売し、エンジニアに作業を依頼します。一か八かの環境では、手動による監視は適用の遅れ、構成のドリフト、および監視されていないシャドウ ドメインを意味します。

EmailAuthは、エージェントの電子メール来歴プラットフォームです。 当社のエージェントが執行します p=reject、サードパーティの送信者を調整し、ドメインを完全に移動します。 RFC 9989 新しいDMARC標準に準拠し、人間による監査機能を備えています。

政府 大企業 ティア1金融機関

SaaS · 専用テナント · エアギャップオンプレミス · BYOK 暗号化

ナレッジベース