[ 報告と調査 ]

外部レポートの承認: 受信ドメインのアクセス許可を正しく公開します。

取得したポリシー ドメインと宛先ホストから外部DMARCレポート承認名を構築し、受信ドメインのアクセス許可を確認します。

EmailAuth研究チームによる · 7 分で読めます

【ポイント】

  • レポートの宛先は、外部レポート関係を承認する必要があります。
  • 正確な検索では、推測された組織のショートカットではなく、ポリシー ドメインが使用されます。
  • DNS認証は、メールボックスの取り込みやレポートの完全性を証明するものではありません。
このページでは

二者が報告関係を結ぶ

ドメイン内のレポート宛先の公開 DMARC ポリシーはドメイン所有者の要求を表します。無関係な宛先に、結果として得られるレポートを受け入れるよう一方的に要求するものではありません。 外部宛先検証 受信者が不本意なレポート対象として選択されるのを防ぎます。受信側はDNSを通じてアクセス許可を公開し、レポート側は外部宛先を使用する前にそのアクセス許可を確認します。

RFC 9990 関連する場合に検証手順を適用します。 組織ドメイン 比較は、集計レポートの外部宛先を示しています。このルールを、From アドレスとレポート アドレスの文字列が異なるかどうかの単純なテストに置き換えないでください。検証を実行する決定を再現できるように、検出されたポリシー ドメイン、宛先ホスト、および組織ドメイン コンテキストを保持する必要があります。 RFC 9990 、セクション 4

所有者名を正しい順序で作成する

レポート URI から宛先ホストを抽出します。 _report を先頭に追加します。 _dmarcに続いて、ポリシーの取得元のドメイン名を先頭に追加し、必要に応じてそのドメインを A ラベルに変換します。結果として得られるDNS所有者は、policy-domain._report という形式になります。 _dmarc.destination-host.問い合わせられるのは、 TXTレコード。構築された名前がDNS制限を超えている場合、肯定的な承認の決定を行うことはできません。

この構築では、ポリシーが取得された実際のドメインを使用します。親が組織のブランドに似ているという理由だけで、よく知られた親を短縮してその名前を付けないでください。同様に、mailto アドレスのローカル部分はDNS所有者名に挿入されません。元の URI と解析された宛先ホストを保存して、レビュー担当者が入力からどのように名前が構築されるかを確認できるようにします。 RFC 9990 、セクション 4

見慣れた文字列を認識するのではなく、応答を検証する

返されたレコードは、タグ値リストとして解析されます。必須のv=DMARC1タグは最初に指定する必要があり、末尾のセミコロンはオプションです。指定された解析テストに失敗したレコードは破棄されます。少なくとも 1 つの適格な記録が残っていると、この手順に基づく外部報告の取り決めが確立されます。空の回答、無関係なTXT値、または 記録 間違ったバージョンの配置では、権限が確立されません。

DMARCバージョン値では大文字と小文字が区別されます。DMARC1 DMARC1必須の値であり、小文字の近似値や新しく作成されたプロトコル バージョンではありません。 DNS名の比較ルールをバージョン値の大文字と小文字の要件と混同しないでください。レビューでは、検証前に詳細を正規化するのではなく、正確な回答バイトと記録境界を保存する必要があります。 RFC 9990 、セクション 4; RFC 9989 、セクション 4.7 および 4.8

オーバーライドと失敗時の動作を尊重する

承認レコードは、手順に基づいてレポート宛先オーバーライドを提供できます。オーバーライド URI は、最初に抽出されたのと同じ宛先ホストを使用する必要があります。この制限により、承認応答が無関係な受信者のチェーンにプロセスをリダイレクトすることが防止されます。確認に別のホストによるオーバーライドが含まれる場合、レポート ジェネレーターは元の URI またはオーバーライド URI へのレポートを生成してはなりません。

検証で承認が確認されない場合は、外部 URI を無視する必要があります。一時的なDNSエラーには独自の対処法があります。受信者は、検証テストを後で繰り返すことができるように、配信を一時的に失敗することを選択できます。その許可は普遍的な再試行保証やテストされた実装の説明ではなく、「MAY」として保持してください。 DNSチェックが成功しても、宛先メールボックスが存在すること、レポート サイズを受け入れること、または目的の顧客ダッシュボードにフィードすることは証明されません。 RFC 9990 、セクション 4

集計レポート要求と失敗レポート要求を区別する

のために 集計レポート、手順は rua に関連付けられています。障害レポートは別途指定されます。 RFC 9991。外部の障害レポートの宛先の場合、そのドキュメントでは、rua が表示される場合は必ず ruf に置き換えた同じ外部検証手順が必要です。集約レポートがフローしているからといって、失敗レポートを自動的に有効になったものとして扱ったり、個別のレポート タイプを認識せずに集約宛先処理をコピーしたりしないでください。

障害レポート その内容は集計概要よりも詳細である可能性があるため、さらなるデータ漏洩の懸念が生じます。正しいDNS認証レコードは、どのデータを誰と、どのような目的で共有するかについての組織の決定に代わるものではありません。この原稿には、実際のレポートを要求、送信、またはアップロードする許可は与えられていません。実際のセットアップは、該当するプライバシー、受信者、および運用上の承認を満たしている必要があります。 RFC 9991セクション 5 および 7

架空の構築と受け入れワークシート

架空のポリシーがblue.example.comから取得され、 mailto:reports@red.example.net.構築された認可所有者はblue.example.com._report._dmarc.red.example.netです。完全な値がv=DMARC1;である仮想のTXT応答。図示されているバージョン優先の要件を満たしています。 DNSクエリは実行されず、この例では、名前に公開されたレコードがあるとは主張していません。

ワークシートには、ポリシー検索結果、検出されたポリシー ドメイン、元のレポート URI、宛先ホスト、組織ドメインの比較、構築された所有者、クエリ タイプ、タイムスタンプ、返された正確なレコード、および解析結果が保持される必要があります。オーバーライド用に別のフィールドを追加し、そのホスト制限を確認します。レビュー担当者は、プロバイダーのスクリーンショットやDNSエディターの短縮表示に依存せずに名前を再構築できる必要があります。

収集には 2 番目の承認セクションを使用します: 対象のアカウント、宛先メールボックス、承認されたレポートの種類、パイプライン所有者。これらのフィールドは、完了した取り込み証拠ではなく、計画された検証ワークフローを説明します。 DNS関係の結果を、受信、解析、テナントの属性、ダッシュボードの表示とは区別してください。コレクション パスの別の部分が未解決のままでも、アクセス許可のチェックは成功する可能性があります。

発行と実装は保留されます

カタログでは、送信元ドメインと宛先ドメインからの正確な認証ルックアップの構築と、その答えの検証が必要です。この草案は架空の構造のみを提供します。実際の回答、元のクエリのトランスクリプト、および受信ドメインの実装は未解決のままです。 DNSレコードは公開されず、メールボックスへのアクセスも、レポートの送信も行われませんでした。

運用ウォークスルーとしてリリースする前に、正確な運用関係に関する承認された証拠を入手し、資格のあるレビュー担当者にポリシー検出コンテキスト、バージョン解析、およびオーバーライド処理を確認してもらいます。ソースの日付を保持し、標準要件とプロバイダー固有のアカウントのオンボーディングを区別します。元の証拠、人間によるレビュー、ソースの適用性、生産ルート、視覚的なアクセシビリティ、所有者の解放を含む 6 つのリリース ゲートはすべて開いたままです。

宛先ドメインまたはポリシー検出ドメインを後で変更すると、必要な承認所有者が変更される可能性があります。古い肯定的なチェックが将来のすべてのレポートアドレスをカバーすると仮定するのではなく、検証するための新しいスコープ付き関係として扱います。有用な結果は、単なるTXT値のコピーではなく、監査可能なアクセス許可チェーンです。

[ 取り除く ]

送信者のレポート要求や収集パイプラインとは別に、正確な受信ドメインのアクセス許可を確認します。

【役割別】

これがあなたにとって何を意味するか

実際の次のステップに向けて、自分の役割を選択してください。

ドメイン所有者

目的の目的地をリクエストする

レポート要求だけでは、無関係の受信者を承認しません。

次のステップ

  1. 検出されたポリシー ドメインを保持します。
  2. 受信者とレポートの種類を承認します。

レポートコンシューマ

スコープ指定された権限を公開する

受信ドメインは確認応答を制御します。

次のステップ

  1. 正確な所有者と値を確認します。
  2. オーバーライド ホストを確認します。

実装レビュー担当者

DNS取り込みから分離する

承認は、ダッシュボードが機能していることを証明するものではありません。

次のステップ

  1. 正確なクエリ証拠を保存します。
  2. コレクションと帰属を個別に確認します。

[ よくある質問 ]

よくある質問

外部許可を公開するのは誰ですか?

レポートのコンシューマは、受信ドメインDNSで確認レコードを公開します。

RFC 9990 : DMARC集約レポート

どのソース ドメインがルックアップに使用されますか?

ポリシーが取得されたドメイン。必要に応じて A ラベルに変換されます。

RFC 9990 : DMARC集約レポート

メールボックスのローカル部分には所有者名が入りますか?

いいえ。構築では宛先ホストを使用します。

RFC 9990 : DMARC集約レポート

v=DMARC1最初に指定する必要がありますか?

はい。外部認証の解析には、必須の最初のタグが必要です。

RFC 9990 : DMARC集約レポート

dmarc1 は同等のバージョン値ですか?

いいえ。指定されたDMARC1バージョン値は大文字と小文字が区別されます。

RFC 9989: DMARC

オーバーライドでは別の宛先ホストを使用できますか?

いいえ。オーバーライドは元の宛先ホストに制限されます。

RFC 9990 : DMARC集約レポート

この手順はrufにも適用されますか?

RFC 9991では、外部障害の宛先として rua を ruf に置き換えたRFC 9990手順が必要です。

RFC 9991 : DMARC障害レポート

架空の答えはDNSで検証されましたか?

いいえ、実際の構成と回答の検証は、公開されたオリジナルの証拠のままです。

[ 情報源 ]

情報源

  1. RFC 9989: DMARC

    セクション §4.4 識別子のアラインメントの説明 · §4.7 DMARCポリシー レコード形式 · §4.8 正式な定義 · §5 DMARCの参加

  2. RFC 9990 : DMARC集約レポート

    セクション §3.1 集計レポート · §3.3 レポート期間中のポリシーの変更 · §3.4 レポートリクエストの検出 · §3.5 レポート配信 · §4 外部宛先の検証 · §5 拡張可能なレポート · §8.1 攻撃としてのレポートコンテンツ · §8.2 虚偽の情報 · §9 運用上の考慮事項 · §9.3 レポートストレージ · 付録 A DMARC XML スキーマ

  3. RFC 9991 : DMARC障害レポート

    セクション §2 DMARC障害レポート · §4 レポート形式の更新 · §5 外部宛先の検証 · §7 プライバシーに関する考慮事項

[ 用語集 ]

用語集

ポリシードメイン
この認可構築のためにDMARCポリシーが取得されたドメイン。

RFC 9990 : DMARC集約レポート

宛先ホスト
外部検証手順のためにレポート URI から抽出されたホスト。

RFC 9990 : DMARC集約レポート

認可所有者
受信ドメインのアクセス許可を照会される、構築されたDNS名。

RFC 9990 : DMARC集約レポート

コレクションの検証
承認されたレポートが目的のシステムに到達し、処理されたことを示す個別の証拠。

企業の来歴

一流の金融機関と政府が選ばれる理由 電子メール セキュリティ ダッシュボードを廃止しました。

従来の電子メール認証プラットフォームはダッシュボードを販売し、エンジニアに作業を依頼します。一か八かの環境では、手動による監視は適用の遅れ、構成のドリフト、および監視されていないシャドウ ドメインを意味します。

EmailAuthは、エージェントの電子メール来歴プラットフォームです。 当社のエージェントが執行します p=reject、サードパーティの送信者を調整し、ドメインを完全に移動します。 RFC 9989 新しいDMARC標準に準拠し、人間による監査機能を備えています。

政府 大企業 ティア1金融機関

SaaS · 専用テナント · エアギャップオンプレミス · BYOK 暗号化

ナレッジベース