[ ヘッダーと配信エラー ]

メッセージサイズの拒否と認証の拒否

認証を変更したり、サイズの大きい添付ファイルを繰り返し再送信したりする前に、送信されたメッセージ全体を測定し、拒否制限を特定します。

EmailAuth研究チームによる · 3 分で読めます

【ポイント】

  • 認証を変更したり、サイズの大きい添付ファイルを繰り返し再送信したりする前に、送信されたメッセージ全体を測定し、拒否制限を特定します。
  • 制限と回避策を分離する
このページでは

メッセージ サイズの拒否は、受信サーバーがすべてのメッセージ認証を評価する前に発生する可能性があります。また、上流サーバーがメッセージを受け入れ、後のホップでより小さい制限が適用された後に表示されることもあります。すべての永続的な拒否を問題として扱うのではなく、拒否するホップでのサイズ状態を診断します。 SPF, DKIM または DMARC 欠陥。

サイズとポリシーおよびストレージを区別する

RFC 3463 、X.3.4 を受信システムにとって大きすぎるメッセージとして定義し、X.2.3 をメールボックスの管理制限を超えるメッセージ長として定義しています。これらは、X.2.2 メールボックスがいっぱいであるとは異なります。製品には独自の制限、単位、説明文が追加されている場合があるため、診断全体をお読みください。一般的な「552」ラベルだけでは、構成された制限を正確に確立することはできません。 RFC 3463セクション 3.3 および 3.4.

認証の失敗は、メッセージ オクテットの数ではなく、アイデンティティ、署名、またはポリシーに関係します。サイズの縮小はDKIM修復ではありません。署名されたコンテンツを変更すると、それ自体が署名を無効にする可能性があるため、承認された置換は通常の署名ワークフローを通過する必要があります。逆に、 SPFで別の IP を許可しても、受信者に許可されるメッセージ サイズは増加しません。独立した証拠が両方とも失敗していることを示していない限り、2 つの調査を別々にしてください。

アドバタイズされた SIZE 機能を正しく読み取る

SMTP SIZE 拡張機能を使用すると、サーバーはサポートをアドバタイズし、オプションで最大メッセージ サイズをそのサーバー内でアドバタイズできるようになります。 EHLO 応答。サポートしているクライアントは、次のように推定サイズを提供できます。 メール送信元、メッセージ全体を送信する前に拒否できるようになります。数字のない SIZE は、固定された最大値の情報を伝えません。 SIZE 0 は、固定最大値が適用されていないことを明示的に示します。どちらも受け入れを保証するものではありません。その後の処理や他のホップでも制約が課される可能性があります。 RFC 1870セクション 3 および 4.

RFC 1870 SIZE の場合、CRLF 行末、ヘッダー、 MIME構造、エンコードされたコンテンツを含むメッセージ オクテットをカウントしますが、DATA 終了ドットと余分なドット詰め込みバイトは除きます。添付ファイルのみをカウントしないでください。 Base64 エンコードではバイナリ データが拡張され、改行と周囲のメッセージ部分によりバイト数が追加されます。見る RFC 2045セクション 6.8。プロバイダーのインターフェイスでは、丸められた単位が異なる方法で表示される場合があります。 2 つの説明のない「MB」ラベルを比較するのではなく、測定されたオクテットと、公表または文書化された正確な制限を記録します。

制御されたバリアントを比較する

サイズ関連のコンテンツのみが異なる 2 つの承認済みバリアントを作成します。シリアル化された小さいサイズと大きいサイズ、および各結果のSMTPステージを保持します。例示的なペアには、同じ短い説明テキストが含まれ、大きな添付ファイルが承認されたアクセス制御されたファイル リンクに置き換えられる場合があります。ファイル リンクが機密資料に適している、または受信者がアクセスできるとは想定しないでください。

RFC 5321セクション4.5.3.1 .7 では、ヘッダーを含めて少なくとも 64K オクテットのメッセージ サイズのサポートが必要です。次の 100,000 オクテットの制限はプロトコルの最小値を超えており、推奨されるプロバイダー設定ではありません。

仮想の算術チェックでは、同じエンドポイントが SIZE 100000 をアドバタイズすると仮定します。想定される 115,900 オクテットのメッセージは、その制限を 15,900 オクテット超えます。想定される 20,100 オクテットの置換は、その 79,900 オクテット下にあります。最初のものは MAIL FROM で拒否できます。 2 番目はさらに処理することができますが、受け入れられるかどうかは保証されていません。これらの数値は作成されたものであり、測定値や実行されたSMTP結果ではありません。これらは、プロバイダーの接続上限については説明しません。

関連する最も狭い制約を修復します

拒否するシステムの所有者に、そのサイズが意図的なサービス制限なのか、組織が管理する設定なのかを尋ねてください。ビジネス ニーズをより小さいファイルで満たせる場合は、メール システム全体の制限を引き上げるのではなく、そのルートを使用してください。制限の変更が許可される場合は、適用する前に、リソースの消費、マルウェアのスキャン、およびダウンストリームの互換性を考慮してください。

永久に拒否された同じコンテンツを変更せずに再試行し続けないでください。オリジナルが別のホップまたは別の受信者で受け入れられなかったことを確認し、以前の試行との明確な関係を付けて、承認された代替案を送信します。独自のメッセージとキューの識別子を保持します。新しいメッセージは、ユーザーが同じ添付ファイルとみなした場合でも、新しい配信イベントです。

最後に、測定されたメッセージ サイズ、識別された拒否制限、および修正された試行の結果を表示します。受信箱の配置とリンクされたコンテンツへの受信者のアクセスは、別個のチェックとして残しておきます。

制限と回避策を分離する

  • 対策: 添付ファイルだけでなく、SIZE 定義を使用してシリアル化されたメッセージ全体をカウントします。
  • 特定: 拒否ホップ、コマンド ステージ、診断および適用可能な制限をキャプチャします。
  • 修復: 承認された小さいメッセージまたはアクセス制御された配信方法を選択します。
  • 再確認: 置換サイズと受信者ごとの結果を記録します。すべてのダウンストリーム制限が一致するとは限りません。
  • 閉じる: SMTP受け入れとは別に受信者のアクセスを確認します。

[ 取り除く ]

認証を変更したり、サイズの大きい添付ファイルを繰り返し再送信したりする前に、送信されたメッセージ全体を測定し、拒否制限を特定します。

【役割別】

これがあなたにとって何を意味するか

実際の次のステップに向けて、自分の役割を選択してください。

IT / メール管理者

送信されたメッセージを測定する

デスクトップ ファイル サイズは不完全な入力です。

次のステップ

  1. EHLOと拒否段階をキャプチャします。
  2. シリアル化されたオクテットを測定します。
  3. 認可されたサイズのバリエーションを比較します。

CISO / SecOps

防御可能な制限を維持する

大きなメッセージの例外は、スキャンとリソースの使用に影響します。

次のステップ

  1. 機密共有を確認します。
  2. 下流の制約を評価します。
  3. 変更の承認を保持します。

創業者 / 非技術系

利用可能な配送方法を選択してください

ビジネス要件は、添付ファイルではなくドキュメントへのアクセスである可能性があります。

次のステップ

  1. 受取人のニーズを確認します。
  2. 適切なファイル共有を承認します。
  3. 不必要なグローバル制限の増加を避けてください。

[ よくある質問 ]

よくある質問

大きな添付ファイルは送信されたメッセージと同じサイズですか?

いいえ。ヘッダー、 MIME境界、転送エンコーディングがシリアル化されたメッセージに追加されます。

EHLO SIZE 数値は何を表しますか?

正の数値は、そのサーバーの固定最大値をオクテット単位で通知します。 SIZE 0 は、固定最大値が適用されていないことを意味します。どちらもすべてのホップで受け入れられることを保証するものではありません。

数字のないSIZEは無制限を意味しますか?

いいえ。数値を省略すると、SIZE 0 とは異なり、固定最大値の情報は提供されません。これは、固定最大値が適用されないことを明示的に意味します。他のチェックでもメールが拒否される可能性があります。

上流ですでに受け入れられたメッセージを後のホップで拒否できますか?

はい。どのホップが受け入れられ、その後どのシステムが失敗を報告したかを保存します。

SPFによってサイズ制限は変わりますか?

いいえ。送信者の承認によって、受信システムの容量や管理上の制限が変更されることはありません。

サイズ例はプロバイダーの取り付け上限を表していますか?

いいえ。100,000 オクテットの制限と 115,900/20,100 オクテットのメッセージ サイズは仮定の計算であり、測定や実行されたテストではありません。

添付ファイルを公開リンクに置き換えることはできますか?

いいえ。承認された共有方法を使用し、対象の受信者がその共有方法にアクセスできることを確認してください。

修理を完了させる証拠は何ですか?

測定されたシリアル化されたサイズ、関連する制限、および文書化された修正試行結果。

[ 情報源 ]

情報源

  1. RFC 5321 SMTP

    セクション §3.3 · §4.1.1.1 · §4.2 · §4.5.3.2 · §4.5.4.1 · §5 · §6.1 · §4.5.3.1.7

  2. RFC 3463拡張メール システムのステータス コード

    セクション §3.2 · §3.3 · §3.4 · §3.5

  3. RFC 1870メッセージ サイズ宣言のためのSMTPサービス拡張

    セクション §3 · §4 · §5 · §6

  4. RFC 2045 : MIMEパート 1

    セクション §6.8

[ 用語集 ]

用語集

オクテット
プロトコル メッセージのサイズをカウントするときに使用される 8 ビット単位。
サイズ拡張
メッセージ サイズを通知および宣言するためのSMTP拡張機能。
MIMEエンコーディング
送信されるサイズを変更できるメッセージ部分の表現。

企業の来歴

一流の金融機関と政府が選ばれる理由 電子メール セキュリティ ダッシュボードを廃止しました。

従来の電子メール認証プラットフォームはダッシュボードを販売し、エンジニアに作業を依頼します。一か八かの環境では、手動による監視は適用の遅れ、構成のドリフト、および監視されていないシャドウ ドメインを意味します。

EmailAuthは、エージェントの電子メール来歴プラットフォームです。 当社のエージェントが執行します p=reject、サードパーティの送信者を調整し、ドメインを完全に移動します。 RFC 9989 新しいDMARC標準に準拠し、人間による監査機能を備えています。

政府 大企業 ティア1金融機関

SaaS · 専用テナント · エアギャップオンプレミス · BYOK 暗号化

ナレッジベース