[ DKIM ]

DKIM簽署金鑰受損的事件回應

包含暴露的簽名權限、替換受影響的密鑰並保留基於證據的事件時間表。

由EmailAuth研究團隊提供 · 3 分鐘閱讀

[ 重點 ]

  • 包含暴露的簽名權限、替換受影響的密鑰並保留基於證據的事件時間表。
  • 新密鑰不會刪除攻擊者現有的存取權限。
在此頁面上

一個妥協的 DKIM 私鑰可以讓攻擊者建立在受影響的簽章域下進行驗證的簽章。將該事件視為簽章授權事件。替換DNS記錄只是遏制的一部分,僅靠DKIM驗證無法區分授權簽署者和持有相同金鑰的攻擊者。

建立受影響的機構

使用私鑰識別簽章域、選擇器、金鑰保管人和每項服務。保留相關的審核日誌、配置和代表性可疑訊息,而無需將機密複製到票證或聊天中。記錄發現時間、可能的暴露視窗以及已知與可疑的情況。

將私鑰盜竊與未經授權的簽署服務存取分開。具有帳戶存取權限的攻擊者可能會在金鑰輪換後繼續簽名,除非包含該存取權限。 DNS管理妥協是另一個需要自己回應的依賴項。在事件負責人的領導下協調這些調查。

停止新的濫用並撤銷舊的驗證路徑

透過核准的事件流程暫停受影響的簽名路線或憑證。 RFC 6376允許透過發布空 p 值來撤銷。一旦發現鑰匙缺失,取出鑰匙也會阻止成功檢索。選擇平台支援的響應並驗證準確 選擇器 和更改之前的網域。

撤銷並不是對每個接收者都是即時的。已評估的快取DNS資料和訊息創建了一個與時間相關的邊界。請勿承諾更改DNS會追溯性地使已發送郵件中的簽名無效或證明不接受任何濫用郵件。

正常輪換重疊保留了對排隊合法訊息的驗證。在妥協過程中,保持暴露的金鑰可驗證也可以保留攻擊者的能力。事件所有者必須權衡遏制措施和延遲郵件故障,而不是自動應用例行重疊計劃。

透過乾淨的路徑恢復簽名

解決暴露原因後,透過受信任的支援流程產生替換密鑰材料。喜歡新的受支援的選擇器,以便可以區分新舊證據。應用目前的加密要求。對於 RSA 簽名, RFC 8301需要 rsa-sha256 而不是 rsa-sha1,並建議至少 2048 位元 鍵。

說明性回應:選擇器 sales1 已公開,並包含其簽章帳戶。乾淨的簽署者使用 sales2,而 sales1 被撤銷。新的受控郵件與 sales2 進行驗證並與 From 保持一致;與 sales1 簽署的延遲郵件可能會失敗。這個例子描述了一個明確的權衡,而不是一個完整的事件或通用接收者行為的保證。

驗證恢復並保持不確定性

測試每一條受影響的路由,而不僅僅是一個郵箱。儲存原始訊息和可信任結果,檢查新選擇器,確認 結盟 並驗證受損的憑證不再授權簽署。查看暴露期間的提供者日誌和接收者報告,注意報告並未涵蓋每個接收者或證明每個訊息的發送者。

維護遏制、 DNS觀察、取代部署和客戶影響評估的時間表。保持取證副本的存取控制。僅與已確定的所有者聯繫以結束事件,以進行後續調查並糾正密鑰保管或存取故障。成功的新簽名證明恢復路線有效;它本身並不能確定早期濫用的全部範圍。

在緊急情況發生之前鍛鍊一下桌面

在此綜合時間軸中,服務帳戶 A 持有 sales1,乾淨帳戶 B 持有 sales2。在零分鐘,包含 A。在第一分鐘,發布 sales1 撤銷。在第二分鐘,虛構的解析器仍然擁有其舊的快取金鑰,因此舊的簽章可能仍然可以在那裡驗證。第三分鐘,開始乾淨的 sales2 路線。在第 30 分鐘,收集每個路由收到的結果並存取證據,而不是僅聲明從DNS恢復。這些時間說明了排序,而不是承諾的傳播間隔。

該書面桌面提出了五個必需的恢復觀察:舊訪問被禁用、暴露原因被包含、新密鑰已發布、新簽名已驗證和新簽名已對齊。新郵件通過但舊訪問仍處於活動狀態的情況無法通過恢復門。滿足所有五個條件的場景會通過建模閘。兩組觀察結果都是綜合的;沒有執行桌面程式、租用戶或訊息測試。在真實事件期間仍然需要實際遏制、快取觀察、批准和訊息測試。

為每個未解決的恢復閘門分配一個擁有者

書面案例 KEY-01 假設替換選擇器 sales2 為 From sales@example.org和d=example.org,但舊服務帳戶仍保持活動狀態。事件擁有者必須保持恢復開放並解決存取控制問題;郵件管理員成功的簽章測試無法彌補這一差距。舊的解析器快取和過去的濫用範圍仍然未知。身分和結果是規定的教學假設,而不是執行的事件。

[ 外帶 ]

新密鑰不會刪除攻擊者現有的存取權限。

[ 按角色 ]

這對您意味著什麼

選擇您的角色以執行後續實際步驟。

IT/郵件管理員

替換整個受影響的路徑

如果攻擊者保留簽章存取權限,則新的DNS資料是不夠的。

後續步驟

  1. 庫存共享密鑰路由。
  2. 部署一個乾淨的支援選擇器。
  3. 驗證每條恢復的路線。

CISO / SecOps

保留可防禦的事件時間表

關鍵曝光後,驗證和歸因是不同的問題。

後續步驟

  1. 包含憑證和DNS存取權限。
  2. 記錄快取和報告不確定性。
  3. 調查並糾正暴露原因。

創辦人/非技術人員

協調遏制和連續性

緊急撤銷可能會影響合法的延遲郵件以及濫用。

後續步驟

  1. 指定事件決策負責人的名稱。
  2. 識別有風險的關鍵訊息。
  3. 批准恢復溝通計劃。

[ 常見問題解答 ]

常見問題

擁有私鑰的攻擊者可以作為我們的域簽署嗎?

他們可以在受影響的金鑰和簽名網域下建立簽名,而接收者可以驗證該金鑰。

輪換密鑰是否會撤銷被盜帳戶的存取權限?

否。單獨包含服務憑證和權限。

空 p 值意味著什麼?

RFC 6376將其定義為已撤銷的金鑰。

DNS是否在所有地方都會立即撤銷?

不會。快取狀態和先前的訊息評估限制了當前變更所證明的內容。

洩漏的金鑰是否應該接收例程重疊?

不是自動的。持續驗證可以防止濫用,因此遏制風險決定決策。

撤銷會改變已經發送的訊息嗎?

它不會追溯更改其原始身份驗證結果或交付決策。

為什麼要使用新的選擇器?

如果支持,它將替換簽名和調查證據與暴露的密鑰分開。

什麼證明康復了?

乾淨的訪問、糾正的監管、新的每條路線經過驗證和對齊的訊息以及記錄的殘留調查。

[ 來源 ]

來源

  1. RFC 6376 :網域金鑰識別郵件簽名

    部分 §3.4 · §3.6.1 · §3.7 · §6.1.2 · §8.3

  2. RFC 8301 : DKIM的加密演算法與金鑰用法更新

    部分 §3.1 · §3.2

  3. RFC 9989 :基於網域的訊息驗證、報告和一致性

    部分 §4.4 · §5.3.1 · §5.3.5 · §7.4 · §11.7

[ 詞彙表 ]

詞彙表

DKIM
基於簽名的機制將選定的訊息內容綁定到簽名域。
SPF
對SPF協定定義的身份的連線發送 IP 進行授權。
DMARC對齊
作者域和成功驗證的識別碼之間所需的域關係。
DKIM選擇器
s 值與簽章域一起使用來定位公共驗證資料。

企業出處

為什麼頂級金融機構和政府 退役了他們的電子郵件安全儀表板。

傳統的電子郵件驗證平台會向您出售儀表板並要求您的工程師來完成這項工作。在高風險環境中,手動監督意味著延遲執行、配置漂移和不受監控的影子域。

EmailAuth是代理電子郵件來源平台。 我們的代理人強制執行 p=reject,保持第三方寄件者一致並將您的網域移至完整狀態 RFC 9989 合規性、新的DMARC標準,以及人機互動審核能力。

政府 大型企業 一級金融機構

SaaS · 專用租賃 · 氣隙本地部署 · BYOK 加密

知識庫