[ 企業營運 ]

離開寄件者並刪除其不再需要的信任

刪除已退休的寄件者的實際權限並驗證共享的合法流是否仍然有效。

由EmailAuth研究團隊提供 · 3 分鐘閱讀

[ 重點 ]

  • 刪除已退休的寄件者的實際權限並驗證共享的合法流是否仍然有效。
  • 分別驗證退役的存取和倖存的服務連續性; DNS刪除無法證明提供者憑證已撤銷。
在此頁面上

取消供應商合約並不一定會消除其為您的網域發送經過驗證的郵件的能力。卸載必須涵蓋剩餘的服務帳戶、憑證、 DNS關係和操作相依性。目的是刪除不必要的權限,同時保留可能共享該權限的合法應用程式。

設定退休界限

確定確切的供應商帳戶、服務目的、所有者和最終授權發送時間。列出計畫作業、重試、排隊訊息、入站回覆、退回處理和整合。確認服務是否完全停止或僅遺失一個網域。在訪問消失之前保留配置和相關證據,並遵守保留和隱私要求。

存貨 SPF 機制, DKIM 鍵或 選擇器 本服務使用的委託、自訂返迴路徑、委託區域、API 憑證、連接器和報告目標。這些是具有不同撤銷步驟的不同相依性。 RFC 6376中指定了DKIM金鑰發布和驗證;過早刪除金鑰可能會影響對已簽署訊息的驗證。 DKIM規範。不要假設合約終止已更改DNS或撤銷 API 令牌。

在刪除之前尋找共享權限

對於每個建議的刪除,請識別依賴相同物件的其他應用程式。 SPF中包含的提供者可以支援多個核准的帳戶。刪除它可能會損害合法郵件;保留它可能會留下比預期更寬的授權路徑。決定是否可以拆分依賴關係或是否可以在其帳戶邊界停用已停用的服務。檢查提供者特定的行為而不是治療 SPF記錄 作為每個使用者的權限列表。 RFC 7208.

記錄停止順序、驗證順序和恢復限制。恢復受損憑證的回滾並不等於恢復意外刪除的DNS記錄。如果懷疑受到損害,請在重新啟用舊權限之前協調回應。正常撤離和緊急遏制可能需要不同的時間,但都需要負責任的決定和證據。

避免讓一次成功的檢查關閉每個依賴項

考慮同一提供者的假設退休計費帳戶和倖存工資帳戶。他們的選擇器不同,但他們的SPF包含是共享的。刪除已停用的選擇器並未表示其 API 憑證已被撤銷,且刪除共用包含可能會影響薪資單。首先將每個物件對應到帳戶邊界和倖存用途,然後批准特定的停止順序。

假設稍後授權的DNS觀察確認退休選擇器不存在,同時沒有提供者帳號撤銷證據可用。將DNS停用記錄為已觀察,將憑證撤銷記錄為待處理。請勿執行未經授權的發送來填補該空白;使用提供者支援的管理證據或明確批准的安全測試。這些是假設的決定,而不是實際的DNS或憑證操作。

排隊合法郵件的保留公鑰與允許新發送的活動憑證具有不同的用途。平衡驗證的連續性與事件所有者的任何可疑妥協;不要採用通用保留延遲或自動恢復洩露的秘密。

驗證移除和連續性

透過經批准的安全方法測試退役路線不再具有預期的權限。單獨測試共享基礎設施的合法服務,包括低容量事務路徑。檢查接收者身分驗證和業務交付結果,而不是僅依賴DNS發布。 DMARC 結果描述 域對齊 和處理,而不是證明您的庫存完整。 RFC 9989.

關閉註銷記錄,刪除依賴關係,故意保留物件、原因、所有者和審核日期。在業務仍需要的地方保留註冊或接收依賴項。監視與退役服務相關的後續觀察結果並調查其來源,而不是假設每個延遲的報告都意味著撤銷失敗。當批准的權限範圍和證據一致時,案件就完成了。

獨立關閉各權限

將帳戶停用、憑證吊銷、 DNS停用和剩餘流檢查作為單獨的結果。即使所有DNS檢查都通過,也將缺少的提供者後檢查標記為掛起。為每個保留的依賴項指定擁有者和安全驗證方法。

[ 外帶 ]

分別驗證退役的存取和倖存的服務連續性; DNS刪除無法證明提供者憑證已撤銷。

[ 按角色 ]

這對您意味著什麼

選擇您的角色以執行後續實際步驟。

IT/郵件管理員

刪除並驗證權限

遵循其所有者的每個依賴關係。

後續步驟

  1. 庫存金鑰和憑證
  2. 檢查共享SPF使用情況
  3. 測試倖存的郵件流

CISO / SecOps

確保回滾安全

復甦絕不能重新造成妥協。

後續步驟

  1. 單獨的日常路徑和緊急路徑
  2. 查看保留的權限
  3. 保留搬遷後的證據

創辦人/非技術人員

批准最終範圍

合約交割和技術交割有所不同。

後續步驟

  1. 確認最後的業務用途
  2. 識別共享服務
  3. 批准剩餘例外情況

[ 常見問題解答 ]

常見問題

取消訂閱是否會撤銷DNS信任?

未必。獨立驗證DNS 、帳戶和憑證變更。

共享的SPF包含可以簡單地刪除嗎?

僅在識別並保護依賴它的其他服務之後。

為什麼要考慮排隊訊息?

停用前簽署的訊息在服務停止後可能仍需要驗證。

是否應該回滾恢復受損的 API 令牌?

不適合自動恢復;與事件所有者協調恢復工作。

哪個範例檢查仍然懸而未決?

即使在授權的DNS觀察中確認已退休的選擇器不存在,提供者憑證撤銷也缺乏證據。

該範例是否撤銷了實際存取權限?

不。這是一個假設的依賴性審查;沒有更改任何帳戶、金鑰、憑證或公共DNS記錄。

這兩個驗證目標是什麼?

確認不需要的權限已被刪除並且合法的共享流仍然有效。

後來的報告能證明離職失敗嗎?

不是靠它自己。檢查報告間隔、觀察路線和相關時間。

[ 來源 ]

來源

  1. RFC 6376 DKIM

    部分 §3.6.2.1 · §6.1.2

  2. RFC 7208 SPF

    部分 §4.6.4 · §5.2

  3. RFC 9989 DMARC

    部分 §4.4 · §4.10.1 · §5.3.5 · §7.4 · §8

[ 詞彙表 ]

詞彙表

離職
服務的受控退役及其關聯的存取和信任依賴關係。
共享依賴
被多個服務使用的物件或權限。
拆除後檢查
更改後進行的觀察,以驗證其預期效果和連續性。

企業出處

為什麼頂級金融機構和政府 退役了他們的電子郵件安全儀表板。

傳統的電子郵件驗證平台會向您出售儀表板並要求您的工程師來完成這項工作。在高風險環境中,手動監督意味著延遲執行、配置漂移和不受監控的影子域。

EmailAuth是代理電子郵件來源平台。 我們的代理人強制執行 p=reject,保持第三方寄件者一致並將您的網域移至完整狀態 RFC 9989 合規性、新的DMARC標準,以及人機互動審核能力。

政府 大型企業 一級金融機構

SaaS · 專用租賃 · 氣隙本地部署 · BYOK 加密

知識庫