[ DKIM ]

为委派的子域分配DKIM所有权

在将子域委托给服务之前定义谁控制DNS 、私钥和发送身份。

由EmailAuth研究团队提供 · 3 分钟阅读

[ 要点 ]

  • 将选择器别名与委派的DNS区域区分开来。
  • 独立命名企业、 DNS和私钥所有者。
  • 在进行更改之前定义依赖关系和脱离。
在此页面上

委派子域可以使发送服务更易于操作,但它也可以分散对组织身份的控制。一个有用的 DKIM 设计将DNS所有者、私钥保管人和企业所有者分开命名。它还准确说明了授权的内容以及授权将如何结束。

不要从发布限制性记录或假设子域仅发送邮件开始。建立其当前和预期目的,包括接收、应用程序使用和继承的依赖关系。 DKIM配置本身并不能决定命名空间是否应该接受消息、为网站提供服务或保持休眠状态。

定义授权边界

区分选择器级别 CNAME 使用 NS 记录委托整个DNS区域。一个 选择器 CNAME指向以下提供商管理的验证数据的特定查找 RFC 1034 §3.6.2。区域代表团为该区域内的名称分配权威责任,但须进一步削减区域,根据 RFC 1034 §4.2;范围可以包括与DKIM无关的记录。在将这两种机制视为可互换之前,请先审查更广泛的权威。

记录完整的选择器查找名称、目标或权威区域、预期域名和提供商帐户。 RFC 6376 §3.1 描述选择器用例和 RFC 6376 §3.6.2.1 定义键查找。它没有规定特定提供商控制面板中的权限。获取提供商的最新说明以及这些权限的负责所有者。

分配三种所有权

企业主知道哪些消息必须继续有效。 DNS所有者可以发布或删除查找或委派。密钥保管人控制私有签名密钥,无论是内部系统还是托管提供商。一个团队可以担任多个角色,但每个职责都应该明确。

询问谁可以轮换密钥、更改签名域、导出证据并禁用发送帐户。公共验证数据不是私人签名密钥。切勿仅仅为了证明这一点而索取提供商的私钥 一个记录 是正确的;使用记录的控制和收到的消息验证来代替。

通过一个范围示例进行工作

说明性设计: receipts.mail.example被分配给计费服务,并使用d=receipts.mail.example和选择器 bill1 支持签名。该组织保留其父DNS ,而提供商控制bill1._domainkey.receipts.mail.example到达的验证材料。根据该确切名称记录账单所有者、 DNS更改所有者和提供商密钥保管人。

如果可见的发件人域是receipts.mail.example ,则身份完全匹配。如果 From 使用mail.example ,则评估配置的 结盟 模式下 RFC 9989 §3.2.10 和组织域发现 RFC 9989 §4.10.2;不要假设严格对齐。传递签名证明了其d域的密码关系,而不是父级下的每个地址都具有相同的业务授权。这是一个设计固定装置,而不是实际租户的结果。

更改前检查隐藏的依赖项

使用子域搜索配置清单以查找计划作业、收购时代的应用程序和旧的活动系统。单独审查接收要求。 DNS委派更改可能影响的不仅仅是DKIM ,而删除选择器可能会影响已使用该选择器签名的延迟消息。

为每个已知的发送路由准备代表性测试。捕获来自、d、s、受信任的接收器结果和对齐,以及DNS答案和时间戳。验证正常路径以及恢复路径。标记为已验证的仪表板是有用的配置证据,但不能替代收到的消息示例。

使离板成为初始设计的一部分

记录如何停止新签名、在计划的过渡期间保留必要的验证以及在依赖关系结束后删除未使用的委派。分别协调帐户访问和 API 凭证;删除一条DNS记录并不能完全关闭提供商。如果怀疑密钥被泄露,安全遏制可以优先于普通重叠。

最终寄存器应显示名称空间用途、授予的权限、所有者、测试和退出条件。该记录可以让下一个管理员区分必要的依赖关系和废弃的指针,而无需根据DNS中的提供者名称进行猜测。

记录下一个决定

在批准之前,将所请求的确切名称和记录类型与预期的权限进行比较。不应将整个区域的一个选择器CNAME默默地替换为 NS 委派。如果提供者需要更广泛的范围,请列出受影响的名称和依赖项并获得负责的所有者的决定。该示例未授予实际的DNS权限。

[ 外卖 ]

将选择器别名与委派的DNS区域区分开来。独立命名企业、 DNS和私钥所有者。在进行更改之前定义依赖关系和脱离。

[ 按角色 ]

这对您意味着什么

选择您的角色以执行后续实际步骤。

IT/邮件管理员

记录准确的权限边界

完整的区域委托可以影响多个签名选择器。

后续步骤

  1. 映射CNAME和 NS 依赖关系。
  2. 记录密钥保管和轮换控制。
  3. 测试在结束前收到签名。

CISO / SecOps

将授权视为持续的信任

DNS控制和私钥访问是单独的权限表面。

后续步骤

  1. 检查委托范围。
  2. 定义妥协遏制。
  3. 需要帐户和DNS卸载证据。

创始人/非技术人员

命名通信所有者

提供商关系需要一个可以确认子域存在原因的企业主。

后续步骤

  1. 列出其发送和接收目的。
  2. 识别不常见的业务消息。
  3. 在启动前批准退出条件。

[ 常见问题解答 ]

常见问题

选择器CNAME与区域委托相同吗?

不。他们授予不同的DNS范围。检查所涉及的完整名称和权限。

RFC 1034 §3.6.2 RFC 1034 §4.2

谁应该拥有私钥?

指定实际托管人,可能是提供者。即使无法导出密钥,所有权也必须明确。

我们需要私钥来验证设置吗?

不需要。验证使用公钥材料和签名消息;私钥应受到保护。

RFC 6376 §6.1.2 RFC 6376 §6.1.3

DKIM是否决定子域是否接收邮件?

不可以。发送和接收要求需要单独决定。

子域签名可以与父域签名一致吗?

当组织域关系合格时,它可以处于宽松的对齐状态;严格对齐需要精确匹配。

RFC 9989 §3.2.10 RFC 9989 §4.10.2

什么隐藏的依赖关系很重要?

预定的应用程序、遗留活动、购买的系统和仍在传输中的邮件都可以依赖于现有的配置。

移除选择器是否就完成了卸载?

不会。帐户、凭证、集成和更广泛的DNS授权可能会保留。

受损的密钥是否应该获得正常的转换重叠?

不是自动的。尽管对延迟邮件有影响,但遏制可能会证明立即撤销是合理的。

RFC 6376 §8.3

[ 来源 ]

来源

  1. RFC 1034

    部分 §3.6.2 · §4.2

  2. RFC 6376

    部分 §1 · §3.1 · §3.5 · §3.6.2.1 · §6.1.2 · §6.1.3 · §8.3

  3. RFC 9989

    部分 §3.2.10 · §4.4 · §4.10.2

[ 词汇表 ]

词汇表

DKIM
使用公钥数据验证的所选消息内容的域关联签名。

RFC 6376 §1

选择器
s 值与 d 签名域一起使用来定位验证数据。

RFC 6376 §3.1 RFC 6376 §3.5

DMARC对齐
经过身份验证的标识符和作者域之间所需的关系。

RFC 9989 §4.4

专区代表团
DNS区域边界在命名空间中分配权威责任。

RFC 1034 §4.2

企业出处

为什么顶级金融机构和政府 退役了他们的电子邮件安全仪表板。

传统的电子邮件身份验证平台会向您出售仪表板并要求您的工程师来完成这项工作。在高风险环境中,手动监督意味着延迟执行、配置漂移和不受监控的影子域。

EmailAuth是代理电子邮件来源平台。 我们的代理人强制执行 p=reject,保持第三方发件人一致并将您的域名移至完整状态 RFC 9989 合规性、新的DMARC标准,以及人机交互审核能力。

政府 大型企业 一级金融机构

SaaS · 专用租赁 · 气隙本地部署 · BYOK 加密

知识库