[ DMARC和政策 ]

用于邮件列表的DMARC :跟踪原始邮件和重新分发的邮件

将列表发送的邮件、发布到列表的邮件和转发给订阅者的邮件分开,然后检查每个路由中哪些经过身份验证的身份仍然有效。

由EmailAuth研究团队提供 · 6 分钟阅读

[ 要点 ]

  • 单独的列表通知、重新分发的帖子和外部列表的使用。
  • 跟踪每个幸存的签名及其与 From 的一致性。
  • 本地策略下的接受不会将DMARC失败转换为通过。
在此页面上

邮件列表部署涉及多个发送身份。托管该列表的域可以发送订阅通知并重新分发由其他域中的人员编写的消息。员工还可以从组织的域发布到其他地方操作的列表。每条路径都需要自己的身份验证和策略评估。

首先命名正在审查的角色。 一个记录 保护列表管理通知不会自动解决重新分发帖子的身份验证问题。有效的列表签名不会自动与原始作者的发件人域对齐。

分离三个邮件流

在更改策略之前构建一个小型路由寄存器:

  • 由列表服务发起的管理邮件,例如订阅确认。
  • 从作者那里收到的帖子并重新分发给订阅者。
  • 用户从您的域发送到外部列表的消息。

对于每个,记录负责的操作员、可见域、信封身份、签名域和转换。保留该路由的软件设置列表,而不是将来自同一服务器的每条消息视为同一流。

这 电子邮件身份链 解释哪些字段很重要。在下面 RFC 9989 §3.2.2、回复地址或友好列表名称不能替换作者域 DMARC 结盟.

比较直接交付和再分配交付

下表是综合比较,并非捕获的消息数据。假设writers.example和lists.example具有适用的有效DMARC策略、已完成的检查和不相关的组织域。假设来自author@writers.example的原始消息已使用d=writers.example正确签名并通过 SPF 授权的原始路由发送。

  • 观察:从域可见;直接路由: writers.example ;保留 From: writers.example的列表重新分配
  • 观察:连接源;直达航线:原件寄送服务;保留 From: 列表服务器的列表重新分发
  • 观察:包络域;直接路由: writers.example ;列表重写后保留 From: lists.example的列表重新分配
  • 观察:原始 DKIM签名;直达路由:本例有效;保留 From 的列表重新分发:取决于签名内容是否存活
  • 观察:附加列表签名;直达路线:没有假定;保留 From: d=lists.example的列表重新分配可以验证
  • 观察: DMARC问题;直接路线:经过的原始身份是否一致?保留 From 的列表重新分配:是否有任何幸存的传递身份仍然与writers.example一致?

在下面 RFC 9989 §4.4.2 和 RFC 7208 §2.4,如果列表将信封重写为lists.example ,则 SPF pass 验证该列表的身份。它与writers.example不一致仅仅因为重新分配是合法的。在下面 RFC 9989 §4.4.1 和 RFC 9989 §5.3.5,如果原始DKIM签名存活并对齐,它仍然可以提供所需的路径。如果列表页脚或更改的签名标头使原始签名无效,则来自不相关列表域的新签名不会替换丢失的对齐。

实际结果取决于实际的转换、签名和接收者。检查两个版本,而不是假设每个列表都保留或破坏相同的材料。

保留消息修改证据

当重新分发消息失败时 DKIM,将原始签名版本与订阅者处的版本进行比较。检查正文更改、主题编辑和其他签名字段,如中所述 RFC 6377 §3.3。稍后添加的正常消息传递标头不会全部使DKIM失效;签名的覆盖范围和 规范化 下的事项 RFC 6376 §3.4 和 RFC 6376 §3.7.

保留每个签名及其 d 和 s 值。一条消息可能有多个签名,一次失败并不意味着每个签名都失败。使用 主体哈希调查 当主体发生变化时,并将该结果与丢失密钥或其他验证错误区分开来。

切勿仅仅因为猜测它会导致失败而删除真正的业务页脚。演示更改并查阅列表运算符支持的配置。有用的修复保留了所需的列表功能,同时使最终的身份行为变得清晰。

评估可用的操作选择

列表操作员可以检查受支持的方法以避免损坏原始签名,签署自己的邮件并选择如何呈现作者身份。正如中所讨论的 RFC 7960 §4.1.3.3,如果服务将可见的发件人重写为列表控制的域,则生成的DMARC评估将涉及该新的作者域。这可能会改变向订阅者显示的身份和回复体验,因此请测试安全性和可用性。

如中所述 RFC 6377 §5.8,将重新分发的邮件签名为列表可以确定该列表域的责任。它本身无法证明原始作者或恢复与不相关的未更改的 From 域的对齐。

对于接收组织来说,本地分析可能会识别出合法的间接路线。在下面 RFC 9989 §5.4,该分析下的验收与DMARC pass 不一样。保留实际结果和任何可用的覆盖解释,并避免将广泛的允许规则视为使用列表基础结构的每条消息的永久解决方案。

选择适合域名实际使用的策略

RFC 9989 §7.4 明确警告不要发布拒绝其一般用户可能会发布到 Internet 邮件列表的域。其互操作性部分描述了用户影响和接收者责任。程序在选择策略时应应用该指导,而不是承诺所有域最终都应使用拒绝。

仅发起受控列表管理通知的域与用户参与许多外部列表的员工域具有不同的用途。在选择政策之前先审查重要的间接流量。域发布拒绝必须应用有效的DKIM签名,并且不能仅依赖SPF 。

保留可重复的列表测试

使用经过批准的测试作者和订阅者帐户。发送直接控制和代表列表帖子,然后在指定的边界内保留版本、路由、时间戳和可信接收者结果 RFC 8601 §7.1。包括实际使用的列表功能,例如页脚和主题前缀。记录影响转换的软件版本和配置。

本指南中的比较并未断言真正的列表执行。在您自己的环境中,保留实际观察结果,并在列出软件、网关、签名或策略更改时重新测试。来自单一路线或接收者的结果并不能建立通用传递。

有用的邮件列表评估显示每条消息的发起者、列表的更改内容、哪些经过身份验证的身份幸存下来以及订阅者的接收者如何处理它。将这些结果保留给列表所有者,以便以后的更改不会从策略标签重新启动调查。

记录决定及其限制

在 From 不变和假设的不相关列表域的情况下,丢失原始传递的DKIM签名既不会留下重写信封SPF ,也不会留下对齐的列表签名。如果原始签名仍然存在,则可以保留路径。 From 重写会创建不同的评估,而不是原始作者域通过的证明。仅DKIM故障无法识别哪一跳更改了内容:同时保留密钥、签名和规范化证据。

[ 外卖 ]

单独的列表通知、重新分发的帖子和外部列表的使用。跟踪每个幸存的签名及其与 From 的一致性。本地策略下的接受不会将DMARC失败转换为通过。

[ 按角色 ]

这对您意味着什么

选择您的角色以执行后续实际步骤。

IT/邮件管理员

比较重新分配的双方。

原始消息和订户副本显示哪些路由和内容更改影响了身份验证。

后续步骤

  1. 分别记录信封和发件人。
  2. 验证每个相关的DKIM签名。
  3. 更改后重新测试启用的列表转换。

CISO / SecOps

使用间接邮件证据批准政策。

限制性政策决策必须考虑员工和自有名单如何使用间接交付。

后续步骤

  1. 在拒绝之前审查列表参与情况。
  2. 缩小本地处理异常范围。
  3. 区分经过验证的列表责任和原始作者身份。

创始人/非技术人员

将社区沟通保持在范围内。

客户社区和专业名单即使数量很小也很重要。

后续步骤

  1. 确定关键业务列表的使用。
  2. 为每个拥有的列表分配一个操作员。
  3. 将回复行为包含在变更接受中。

[ 常见问题解答 ]

常见问题

邮件列表的DKIM通行证是否可以证明原作者的DMARC通行证?

不可以。列表域的签名可以在不与未更改的作者域一致的情况下进行验证。检查所有签名及其对齐方式。

RFC 9989 §4.4.1 RFC 9989 §5.3.5

为什么邮件经过列表后SPF会发生变化?

最终接收者会看到列表的连接源和用于重新分发的信封标识。该路由与原始发送交易不同。

RFC 7208 §2.4

每个页脚都会破坏DKIM吗?

影响签名内容的修改可能会使签名无效,但实际的签名、规范化和转换很重要。比较签名版本和重新分发版本。

RFC 6376 §3.4 RFC 6376 §3.7 RFC 6377 §3.3

原始DKIM可以通过列表保留DMARC路径吗?

是的,当原始签名仍然有效并与发件人一致时。不要在没有检查实际重新分发的消息的情况下假设生存。

RFC 9989 §5.3.5

如果列表重写 From 会发生什么变化?

用于后续DMARC评估的作者域更改为重写的域。还测试作者身份显示和回复行为。

RFC 9989 §3.2.2 RFC 7960 §4.1.3.3

具有 Internet 邮件列表用户的员工域是否应该始终发布拒绝信息?

不会。RFC RFC 9989警告不要拒绝该用途,并提供与政策决定相关的互操作性指导。

RFC 9989 §7.4

受控列表测试应该保留什么?

保持直接控制、重新分发的样本、信封和签名身份、转换、时间戳、配置上下文和可信订户端结果。

收件人接受是否意味着邮件已通过DMARC ?

未必。接收器可以使用本地分析来接受故障。将验证与处理分开记录。

RFC 9989 §5.4

[ 来源 ]

来源

  1. RFC 9989

    部分 §3.2.2 · §4.4.1 · §4.4.2 · §5.3.5 · §5.4 · §7.4

  2. RFC 7208

    部分 §2.4

  3. RFC 6376

    部分 §3.4 · §3.7

  4. RFC 8601

    部分 §7.1

  5. RFC 6377

    部分 §3.3 · §5.8

  6. RFC 7960

    部分 §4.1.3.3

[ 词汇表 ]

词汇表

列出签名
由列表操作员提供的DKIM签名,负责其重新分发的消息;其域名可能与原始作者域名不同。

RFC 6377 §5.8 RFC 9989 §4.4.1

作者域
消息发件人字段中的域用作DMARC对齐参考。

RFC 9989 §3.2.2

企业出处

为什么顶级金融机构和政府 退役了他们的电子邮件安全仪表板。

传统的电子邮件身份验证平台会向您出售仪表板并要求您的工程师来完成这项工作。在高风险环境中,手动监督意味着延迟执行、配置漂移和不受监控的影子域。

EmailAuth是代理电子邮件来源平台。 我们的代理人强制执行 p=reject,保持第三方发件人一致并将您的域名移至完整状态 RFC 9989 合规性、新的DMARC标准,以及人机交互审核能力。

政府 大型企业 一级金融机构

SaaS · 专用租赁 · 气隙本地部署 · BYOK 加密

知识库