[ 报告与调查 ]

根据报告和DNS证据构建发件人级调查时间表

建立一个时间表,将消息观察、报告到达、 DNS发布和测试证据分开,而无需发明事件精度。

由EmailAuth研究团队提供

[ 要点 ]

  • 保持观察间隔、到达、变化和测试不同。
  • 当前的DNS和后来的一项测试无法重建早期的接收器行为。
  • 保留相互竞争的解释和来源层面的不确定性。
在此页面上

身份验证事件通常包含多个时钟:报告的覆盖间隔、报告的到达、 DNS更改、应用程序部署和受控测试。只有当每个事件都保持其原始含义时,将它们放在一个时间线上才有帮助。每日一 汇总报告 通常无法告诉您每条包含的消息失败的确切时间。

建立共同的时间基础

参考: RFC 9990 §3.1.1.4, RFC 9990 §3.5.4.

将显示的时间戳标准化为声明的时区,同时保留原始值和精度。记录时钟源和已知的不确定性。将报告间隔与到达时间戳和摄取时间戳区分开来。延迟发送的报告不应被绘制为附件到达时的新的发送突发。

将调查范围扩大到作者域并尽可能验证服务。将未分类的来源分开。保留报告者和报告身份、消息计数、来源组和评估身份,以及重复和重叠决策。这些细节决定了哪些观察结果可以合法地进行比较。

添加DNS证据而不重写历史记录

参考: RFC 1034 §3.6, RFC 8767 §4, RFC 9990 §3.3.

记录批准的更改、预期发布时间、权威观察结果和任何解析器样本,包括查找时间和返回的 TTL。当前的DNS答案确定了该查找现在观察到的内容;这并不是每个接收者之前看到的完整历史。

DNS缓存问题如下 RFC 1034 §3.6;合格的发球陈旧行为 RFC 8767 §4 可以将缓存的使用扩展到超出正常新鲜度。不要声称所有接收器在发布时都已切换,或者恰好有一个接收器稍后显示。保留先前的配置、更改日志和证据限制。如果报告间隔跨越策略更改,请将其标记为混合或可能混合,而不是将每个观察值分配给最终策略。

添加申请和接收者证据

参考: RFC 5321 §4.2.5.

将应用程序部署、网关更改和签名更改放在DNS事件旁边。将受控测试作为单独观察,并包含其实际路线、接收器和结果。申请日志可能会显示提交或接受的跳跃;它不一定确定最终交付。

使用这些证据类型来测试相互竞争的解释。 DNS编辑后失败增加也可能与更改签名内容的新模板同时发生。相关性缩小了调查范围,但在没有进一步证据的情况下无法确定原因。

在有限的时间范围内工作

说明性案例:报告涵盖 00:00 至 24:00 UTC。 12:00 记录策略变更,并在 12:20 通过对照测试 DKIM。该报告包含 80 个通过的观察结果和 20 个未通过的观察结果,于第二天早上 05:00 到达。

您可以在 12:20 陈述间隔总计和成功测试。您不能仅仅因为测试较晚通过,就将所有 20 次失败都分配到中午之前。下一步是获取更窄的接收器或应用证据,或运行其他代表性测试。 05:00到达是一次收集事件,而不是20次失败的时间。

以正确强度的因果陈述结束

将结论标记为观察到的、证实的或仍然假设的。列出支持可疑原因的证据以及未排除的任何相互矛盾的解释。如果不可能精确连接,则保留不确定性,而不是在图表上绘制精确的故障边界。

保存带有源参考、查询修订、包含的时间间隔和所有权分类的时间线。记录下一个验证触发点,例如修复后的第一个完整的可比较报告期。可重复使用的时间线应该允许另一位分析师重建事实和结论的局限性。

继续调查

使用 汇总报告演练 对于基础字段和 对准诊断指南 当原始身份验证成功不满足时 DMARC.

将插图保留在证据范围内

对于虚构的 80 次通过/20 次失败间隔,将所有 20 次失败时间保持未知。 12:20 测试是稍后的观察,05:00 到达是收集事件。没有执行真正的DNS查找或身份验证测试,并且时间线没有找到经过验证的因果切换。

[ 外卖 ]

保持观察间隔、到达、变化和测试不同。当前的DNS和后来的一项测试无法重建早期的接收器行为。保留相互竞争的解释和来源层面的不确定性。

[ 按角色 ]

这对您意味着什么

选择您的角色以执行后续实际步骤。

IT/邮件管理员

保留原始时间和标准化视图。

将收据与观察间隔分开。保留DNS和受控测试证据。

后续步骤

  1. 保留原始时间和标准化视图。
  2. 将收据与观察间隔分开。
  3. 保留DNS和受控测试证据。

CISO / SecOps

挑战不受支持的因果精度。

记录替代解释。需要可重复的修复后比较。

后续步骤

  1. 挑战不受支持的因果精度。
  2. 记录替代解释。
  3. 需要可重复的修复后比较。

创始人/非技术人员

询问时间表实际上证明了什么。

让业务更改在DNS事件旁边可见。分配下一个证据收集步骤。

后续步骤

  1. 询问时间表实际上证明了什么。
  2. 让业务更改在DNS事件旁边可见。
  3. 分配下一个证据收集步骤。

[ 常见问题解答 ]

常见问题

报告到达时间是消息发送时间吗?

不需要。将覆盖的间隔时间、到达时间和摄入时间分开。

RFC 9990 §3.1.1.4

每日报告可以识别故障分钟吗?

通常不会。它将报告的时间间隔内的观察结果分组。

RFC 9990 §3.1.1.4

当前的DNS是否证明了昨天的政策?

否。保留该索赔的变更记录和历史观察结果。

RFC 9990 §3.3

一个 TTL 是否可以证明每个接收器都已更新?

不会。单次查找和 TTL 不会建立通用接收器状态。

RFC 8767 §4

如果该间隔跨越政策变化怎么办?

保留更改并将间隔标记为混合或可能混合。

RFC 9990 §3.3

后来通过的测试是否可以对早期失败进行分类?

不。它确定了该测试的结果,而不是其他观察结果的时间或原因。

应该如何处理竞争变化?

将部署、模板和网关放在时间线上并测试可行的替代方案。

最终的时间线应该保留什么?

原始时间戳、精度、来源参考、范围、结论和未解决的问题。

[ 来源 ]

来源

  1. RFC 9990

    部分 §3.1.1.4 · §3.3 · §3.5.4

  2. RFC 1034

    部分 §3.6

  3. RFC 8767

    部分 §4

  4. RFC 5321

    部分 §4.2.5

[ 词汇表 ]

词汇表

观察间隔
报告周期以 UTC 纪元秒描述,而不是单个消息的时间戳。

RFC 9990 §3.1.1.4

因果假设
在证据支持这种联系之前,提出的解释与观察到的事件仍然不同。

企业出处

为什么顶级金融机构和政府 退役了他们的电子邮件安全仪表板。

传统的电子邮件身份验证平台会向您出售仪表板并要求您的工程师来完成这项工作。在高风险环境中,手动监督意味着延迟执行、配置漂移和不受监控的影子域。

EmailAuth是代理电子邮件来源平台。 我们的代理人强制执行 p=reject,保持第三方发件人一致并将您的域名移至完整状态 RFC 9989 合规性、新的DMARC标准,以及人机交互审核能力。

政府 大型企业 一级金融机构

SaaS · 专用租赁 · 气隙本地部署 · BYOK 加密

知识库