[ 报告与调查 ]

DNS在报告窗口期间发生变化:保留历史上下文

根据收集观察结果时存在的配置历史记录来解释报告。

由EmailAuth研究团队提供

[ 要点 ]

  • 当前的DNS无法重建每个早期接收者的观察结果。
  • 将策略快照、一致的评估和处置分开。
  • 注释转换并保留同时更改的证据。
在此页面上

当前的DNS查找无法证明接收者之前在报告窗口中使用的内容。策略更改可以跨越报告边界、 DNS缓存状态和接收器生成实践。在解释报告与今天的记录之间明显不匹配之前,请保留历史。

保存更改时间表

参考: RFC 8767 §4.

记录新旧 DMARC记录、受影响的域、批准的变更时间、权威观察和相关 TTL 信息。保存相关 SPF 和 DKIM 分别改变。策略编辑和发件人身份验证修复可能会同时发生,但会解释生成的报告的不同方面。

使用观察方法记录 UTC 时间。给定时间的权威答案确定了服务器当时返回的内容;它并不能确定每个接收者立即丢弃缓存的答案。避免发明的通用传播期限。合格的发球陈旧行为 RFC 8767 §4 可以保留超出正常 TTL 新鲜度的可用数据。

阅读所报告的政策的上下文

参考: RFC 9990 §3.3, RFC 9989 §5.4.

RFC 9990 第 3.3 节描述了变更期间的混合策略报告。接收方可能会生成一段时间内的多个报告,也可能生成一个其观察结果跨越策略状态的报告,同时其policy_published 元素包含一个配置。该报告的一个策略快照不是逐条消息的DNS审核。

分别检查覆盖的时间间隔、上报的配置和处理信息。报告的处置也不能替代一致的身份验证结果。接收方本地决策可能与域所有者请求的处理不同。

完成过渡工作

案例说明:业主变更 p=none 到 p=quarantine 世界标准时间 12:00。报告涵盖 00:00–24:00,并记录最终发布的隔离偏好。它仍然可以包括与先前政策相关的早期观察或处理。仅这种不匹配并不能证明接收者忽视了它已经遵守的政策。

正确的调查会比较更改日志、报告器窗口和可用的消息级示例。如果特定于策略的报告是分开的,请保留其身份并在求和之前检查重叠情况。不要重写旧的观察结果以继承当前的DNS状态。

单独验证实际变化

通过重要途径查看权威出版物和代表性后续消息。记录可信的身份验证结果和任何特定于接收者的发现。干净的后续报告间隔可以提供额外的证据,但它和当前的DNS查找都无法证明每个接收器的行为。

使用配置事件对图表进行注释,并保持更改前、过渡和后期间隔可区分。通过观察到的结果、未解决的实施差异和恢复标准来结束变更。当历史报告保留当时存在的不确定性时,它是最有用的。

保留变更证据包

将批准的记录差异、发布观察结果、测试消息引用和相关报告标识放入一份访问控制记录中。请注意附近部署的任何其他更改,包括网关转换或提供商签名更新。这些混杂因素可以解释身份验证的转变,否则这种转变似乎与策略编辑相关。将分析师的解释与原始报告分开记录,以便以后的审阅者可以重新审视它。如果关键路由显示无法解释的故障,请使用明确的停止条件来扩展到其他域。

继续调查

使用 汇总报告演练 解释底层字段和 对准诊断指南 当原始身份验证通行证不满足时 DMARC.

执行综合证据

提供的本地重新运行合成现场装置代表间隔秒 43,200 从无到隔离的政策过渡。该报告涵盖第二个 0 到 86,400,po​​licy_published 记录了p=quarantine.域brand.example 。相对秒数使其成为模型,而不是历史DNS记录。处理两个提供的记录:

  • 夹具行:计费;数量:90;处置:无;对齐DKIM :通过;对齐SPF :失败;所有权证据:仅作为提供的固定装置事实而为人所知
  • 夹具行:来源不明;数量:10;处置:无;对齐DKIM :失败;对齐SPF :失败;所有权证据:未分类

执行的算术产生 100 个观察值、90 个对齐的通过和 10 个对齐的失败。字段到决策链是特定的:date_range 跨越更改,policy_published 是一个快照,并且 10 次失败的无处置无法识别何时评估这些消息。使用历史政策观察和授权样本调查这 10 个。不要自动给它们贴上更改前的标签,也不要断定接收者忽略了隔离。已知的计费装置不需要对此证据进行身份验证修复,因为其对齐的DKIM通过了,尽管业务交付仍然需要单独的证据。真实服务归属、 DNS观察和接收器样本仍有待确定。

保持决策的界限

本地练习计算了 90 次提供的对齐通过和 10 次失败,但 10 次失败的评估时间未知。该模型无法从无处置中推断出变更前时间或接收器不合规情况。未执行DNS查找、策略更改或接收器测试。

[ 外卖 ]

当前的DNS无法重建每个早期接收者的观察结果。将策略快照、一致的评估和处置分开。注释转换并保留同时更改的证据。

[ 按角色 ]

这对您意味着什么

选择您的角色以执行后续实际步骤。

IT/邮件管理员

保存旧的和新的DNS值。

保留基础观察结果并使用上述工作流程将实际故障阶段与假设分开。

后续步骤

  1. 保存旧的和新的DNS值。
  2. 使用更改事件注释报告窗口。
  3. 验证后续消息行为。

CISO / SecOps

避免当前DNS具有追溯确定性。

在根据这些调查结果做出安全决策之前,请保持覆盖范围、来源和剩余不确定性可见。

后续步骤

  1. 避免当前DNS具有追溯确定性。
  2. 审查无法解释的转变结果。
  3. 保留审计证据和决策所有者。

创始人/非技术人员

需要经过批准的变更历史记录。

将此报告任务与自己的业务决策联系起来,并需要与其影响相称的证据。

后续步骤

  1. 需要经过批准的变更历史记录。
  2. 将过渡数据与稳态结果分开。
  3. 保持恢复标准可见。

[ 常见问题解答 ]

常见问题

今天的DNS答案是否解释了昨天的报告?

未必。保留相关的历史配置和时序。

RFC 9990 §3.3

一份报告能否包含对政策变化的观察?

是的。 RFC 9990明确描述了更改期间的混合策略报告。

RFC 9990 §3.3

policy_published 是每条消息的历史记录吗?

否。它包含报告的一项策略配置。

RFC 9990 §3.3

是否应该使用当前策略重新标记旧行?

不。保留他们报告的上下文并单独注释以后的解释。

TTL 能否证明每个接收器都在同一时刻切换?

否。记录与缓存相关的不确定性和实际观察结果。

RFC 8767 §4

不同的处置是否证明不合规?

并不孤单。考虑观察到的策略、转换时间和接收者本地处理。

RFC 9990 §3.3 RFC 9989 §5.4

为什么将DKIM更改与策略更改分开?

即使部署在一起,它们也会影响身份验证和处理的不同部分。

应该怎样结束DNS变更审核?

发表证据、代表性消息结果、后来的报告背景和剩余限制。

[ 来源 ]

来源

  1. RFC 9989

    部分 §5.4

  2. RFC 9990

    部分 §3.3

  3. RFC 8767

    部分 §4

[ 词汇表 ]

词汇表

已发布的策略快照
即使观察跨越配置更改,报告也包含一个策略配置。

RFC 9990 §3.3

服务陈旧行为
限定解析器使用超出正常新鲜度的缓存DNS数据; TTL 本身并不是通用的变更截止日期。

RFC 8767 §4

企业出处

为什么顶级金融机构和政府 退役了他们的电子邮件安全仪表板。

传统的电子邮件身份验证平台会向您出售仪表板并要求您的工程师来完成这项工作。在高风险环境中,手动监督意味着延迟执行、配置漂移和不受监控的影子域。

EmailAuth是代理电子邮件来源平台。 我们的代理人强制执行 p=reject,保持第三方发件人一致并将您的域名移至完整状态 RFC 9989 合规性、新的DMARC标准,以及人机交互审核能力。

政府 大型企业 一级金融机构

SaaS · 专用租赁 · 气隙本地部署 · BYOK 加密

知识库